using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)";
string input = @"Audit Success,08/08/2017 16:22:09,Microsoft-Windows-Eventlog,1100,Service shutdown,The event logging service has shut down.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}