const regex = /(?<=[^/])\/(?=[^\/])([\w\s\S]*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^\/])\\\/(?=[^\\\/])([\\w\\s\\S]*)$', 'g')
const str = `https://documentosavanzopr.s3.amazonaws.com/1090525908/3/Requests/13645/paymentSupport-a3a27d291f20b743.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}