import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^/])\\/(?=[^\\/])([\\w\\s\\S]*)$";
final String string = "https://documentosavanzopr.s3.amazonaws.com/1090525908/3/Requests/13645/paymentSupport-a3a27d291f20b743.pdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}