// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<scheme>.*?):\/\/(?<host>.*?)(?<path>\/[^?]*)|&?(?<name>[^\?]+?)=(?<value>[^&#]*)|#(?<fragment>.*)").unwrap();
let string = "https://pinaoffer.com/bazar?code=5kfU99TPUOyfr71lut94aSQw1pJn09&scaw=scafgaw&acdw=awcaw#jscasw";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}