$re = '/^(?<scheme>.*?):\/\/(?<host>.*?)(?<path>\/[^?]*)|&?(?<name>[^\?]+?)=(?<value>[^&#]*)|#(?<fragment>.*)/m';
$str = 'https://pinaoffer.com/bazar?code=5kfU99TPUOyfr71lut94aSQw1pJn09&scaw=scafgaw&acdw=awcaw#jscasw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);