import Foundation
let pattern = #"(https?://)?(w{3}.)?(.{1,})/(\d{1,})(.cms)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://timesofindia.indiatimes.com/india/with-focus-on-indo-pacific-india-australia-assert-need-for-stronger-defence-trade-ties/articleshow/98551278.cms
https://timesofindia.indiatimes.com/india/five-steps-to-fix-our-airports-ps-its-not-rocket-science/articleshow/96647017.cms
https://timesofindia.indiatimes.com/india/she-lost-six-organs-to-cancer-that-hasnt-stopped-her-from-living/articleshow/97724882.cms
https://timesofindia.indiatimes.com/india/why-india-us-can-be-a-good-tech-partnership/articleshow/97680052.cms
http://www.timesofindia.indiatimes.com/india/ballooning-options-to-spy/articleshow/97660486.cms
timesofindia.indiatimes.com/india/we-the-people-should-know-who-they-are/articleshow/97739545.cms
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)