use strict;
my $str = 'https://timesofindia.indiatimes.com/india/with-focus-on-indo-pacific-india-australia-assert-need-for-stronger-defence-trade-ties/articleshow/98551278.cms
https://timesofindia.indiatimes.com/india/five-steps-to-fix-our-airports-ps-its-not-rocket-science/articleshow/96647017.cms
https://timesofindia.indiatimes.com/india/she-lost-six-organs-to-cancer-that-hasnt-stopped-her-from-living/articleshow/97724882.cms
https://timesofindia.indiatimes.com/india/why-india-us-can-be-a-good-tech-partnership/articleshow/97680052.cms
http://www.timesofindia.indiatimes.com/india/ballooning-options-to-spy/articleshow/97660486.cms
timesofindia.indiatimes.com/india/we-the-people-should-know-who-they-are/articleshow/97739545.cms';
my $regex = qr/(https?://)?(w{3}.)?(.{1,})/(\d{1,})(.cms)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}