// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([r])([1-9A-HJ-NP-Za-km-z]{24,34})$").unwrap();
let string = "// valid addresses
rf1BiGeXwwQoi8Z2ueFYTEXSwuJYfV2Jpn
r9kiSEUEw6iSCNksDVKf9k3AyxjW3r1qPf
rs2qdz5stxyWeMk6sNz5mLY6h5xxPYNJ8u
rfe8yiZUymRPx35BEwGjhfkaLmgNsTytxT
rPE9dw1gR8ravY2o25zudXmj2L28UTNt4D
r9vbV3EHvXWjSkeQ6CAcYVPGeq7TuiXY2X
// invalid addresses (with O, I, l or 0)
rPE9dw1gR8ravY2o25zudXmj2L20UTNt4D
r9vbV3EHvXWjSkeQ6CAcYVPGel7TuiXY2X
r9vbV3EHvXWjSkeQ6CAcYVPGeqOTuiXY2X
r9vbV3EHvXWjSkeQ6CAcYVPGeqITuiXY2X
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}