# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([r])([1-9A-HJ-NP-Za-km-z]{24,34})$"
test_str = ("// valid addresses\n"
"rf1BiGeXwwQoi8Z2ueFYTEXSwuJYfV2Jpn\n"
"r9kiSEUEw6iSCNksDVKf9k3AyxjW3r1qPf\n"
"rs2qdz5stxyWeMk6sNz5mLY6h5xxPYNJ8u\n"
"rfe8yiZUymRPx35BEwGjhfkaLmgNsTytxT\n"
"rPE9dw1gR8ravY2o25zudXmj2L28UTNt4D\n"
"r9vbV3EHvXWjSkeQ6CAcYVPGeq7TuiXY2X\n\n"
"// invalid addresses (with O, I, l or 0)\n"
"rPE9dw1gR8ravY2o25zudXmj2L20UTNt4D\n"
"r9vbV3EHvXWjSkeQ6CAcYVPGel7TuiXY2X\n"
"r9vbV3EHvXWjSkeQ6CAcYVPGeqOTuiXY2X\n"
"r9vbV3EHvXWjSkeQ6CAcYVPGeqITuiXY2X\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.