// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$").unwrap();
let string = "13/10/2022
10/10/2022
13/10/22
10/10/22
13-10-2022
10-10-2022
13-10-22
10-10-22
131022
101022
13102022
10102022
20221013
20221010
2022-10-13
2022-10-10
2022/10/13
2022/10/10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}