package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$`)
var str = `13/10/2022
10/10/2022
13/10/22
10/10/22
13-10-2022
10-10-2022
13-10-22
10-10-22
131022
101022
13102022
10102022
20221013
20221010
2022-10-13
2022-10-10
2022/10/13
2022/10/10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}