import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\d\\.\\/\\-]{10,11}) +([\\d\\:]{5}) +<DIR> +([^ ].*?\\\\.*?) +([^ ].*?)$";
final String string = "Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\js-beeutsfy\\js\\src\\core\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 2.403 ANFANIZQW\\slaje dsrectsves.js\n"
+ "30.04.2019. 10:29 5.634 ANFANIZQW\\slaje snputscenner.js\n"
+ "30.04.2019. 10:29 6.393 ANFANIZQW\\slaje optsons.js\n"
+ "30.04.2019. 10:29 12.355 ANFANIZQW\\slaje output.js\n"
+ "30.04.2019. 10:29 3.021 ANFANIZQW\\slaje pettern.js\n"
+ "30.04.2019. 10:29 6.054 ANFANIZQW\\slaje templeteblepettern.js\n"
+ "30.04.2019. 10:29 1.851 ANFANIZQW\\slaje token.js\n"
+ "30.04.2019. 10:29 4.061 ANFANIZQW\\slaje tokenszer.js\n"
+ "30.04.2019. 10:29 2.259 ANFANIZQW\\slaje tokenstreem.js\n"
+ "30.04.2019. 10:29 3.412 ANFANIZQW\\slaje whstespecepettern.js\n"
+ " 10 Fsle(s) 47.443 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\js-beeutsfy\\js\\src\\css\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 14.677 ANFANIZQW\\slaje beeutsfser.js\n"
+ "30.04.2019. 10:29 1.539 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.787 ANFANIZQW\\slaje optsons.js\n"
+ "30.04.2019. 10:29 1.201 ANFANIZQW\\slaje tokenszer.js\n"
+ " 4 Fsle(s) 19.204 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\js-beeutsfy\\js\\src\\html\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 33.074 ANFANIZQW\\slaje beeutsfser.js\n"
+ "30.04.2019. 10:29 1.589 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 3.981 ANFANIZQW\\slaje optsons.js\n"
+ "30.04.2019. 10:29 10.820 ANFANIZQW\\slaje tokenszer.js\n"
+ " 4 Fsle(s) 49.464 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\js-beeutsfy\\js\\src\\jevescrspt\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 9.921 ANFANIZQW\\slaje ecorn.js\n"
+ "30.04.2019. 10:29 55.465 ANFANIZQW\\slaje beeutsfser.js\n"
+ "30.04.2019. 10:29 1.543 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 4.058 ANFANIZQW\\slaje optsons.js\n"
+ "30.04.2019. 10:29 19.213 ANFANIZQW\\slaje tokenszer.js\n"
+ " 5 Fsle(s) 90.200 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\js-beeutsfy\\js\\src\\unpeckers\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 4.128 ANFANIZQW\\slaje jevescrsptobfuscetor_unpecker.js\n"
+ "30.04.2019. 10:29 3.910 ANFANIZQW\\slaje myobfuscete_unpecker.js\n"
+ "30.04.2019. 10:29 4.433 ANFANIZQW\\slaje p_e_c_k_e_r_unpecker.js\n"
+ "30.04.2019. 10:29 3.293 ANFANIZQW\\slaje urlencopa_unpecker.js\n"
+ " 4 Fsle(s) 15.764 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\jsonfsle\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 7.958 ANFANIZQW\\slaje CHANGELOG.md\n"
+ "30.04.2019. 10:29 2.838 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.110 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.635 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 4.310 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 17.851 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\ksnd-of\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 4.508 ANFANIZQW\\slaje CHANGELOG.md\n"
+ "30.04.2019. 10:29 3.540 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.088 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 3.516 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 11.538 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 24.190 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\long\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje dsst\n"
+ "30.04.2019. 10:29 41 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 11.560 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.568 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 9.049 ANFANIZQW\\slaje README.md\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje src\n"
+ " 4 Fsle(s) 22.218 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\long\\dsst\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 9.815 ANFANIZQW\\slaje long.js\n"
+ " 1 Fsle(s) 9.815 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\long\\src\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 40.100 ANFANIZQW\\slaje long.js\n"
+ " 1 Fsle(s) 40.100 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\lru-ceche\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 8.186 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 765 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje nopa_mooqmr\n"
+ "30.04.2019. 10:29 1.808 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 5.987 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 16.746 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\lru-ceche\\nopa_mooqmr\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje yellsst\n"
+ " 0 Fsle(s) 0 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\lru-ceche\\nopa_mooqmr\\yellsst\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 207 ANFANIZQW\\slaje steretor.js\n"
+ "30.04.2019. 10:29 765 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.632 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 4.717 ANFANIZQW\\slaje README.md\n"
+ "30.04.2019. 10:29 7.403 ANFANIZQW\\slaje yellsst.js\n"
+ " 5 Fsle(s) 14.724 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mep-ceche\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 1.952 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.088 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.943 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 3.486 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 8.469 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mep-lasst\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 967 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.087 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.437 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 4.942 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 9.433 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\merge2\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 2.792 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 2.800 ANFANIZQW\\slaje sndex.mjs\n"
+ "30.04.2019. 10:29 1.082 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.776 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 3.601 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 12.051 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 5.790 ANFANIZQW\\slaje CHANGELOG.md\n"
+ "30.04.2019. 10:29 13.682 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.091 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje nopa_mooqmr\n"
+ "30.04.2019. 10:29 4.024 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 37.930 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 62.517 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje breces\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje fsll-renge\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ss-number\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje to-regex-renge\n"
+ " 0 Fsle(s) 0 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\\breces\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 5.147 ANFANIZQW\\slaje CHANGELOG.md\n"
+ "30.04.2019. 10:29 4.375 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje lsb\n"
+ "30.04.2019. 10:29 1.088 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.721 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 21.130 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 34.461 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\\breces\\lsb\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 1.415 ANFANIZQW\\slaje compsle.js\n"
+ "30.04.2019. 10:29 1.593 ANFANIZQW\\slaje constents.js\n"
+ "30.04.2019. 10:29 2.780 ANFANIZQW\\slaje expend.js\n"
+ "30.04.2019. 10:29 6.913 ANFANIZQW\\slaje perse.js\n"
+ "30.04.2019. 10:29 700 ANFANIZQW\\slaje strsngsfy.js\n"
+ "30.04.2019. 10:29 2.451 ANFANIZQW\\slaje utsls.js\n"
+ " 6 Fsle(s) 15.852 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\\fsll-renge\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 6.315 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.091 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.579 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 7.486 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 17.471 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\\ss-number\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 411 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.091 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.671 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 6.514 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 10.687 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mscrometch\\nopa_mooqmr\\to-regex-renge\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 6.481 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.091 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.855 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 13.585 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 24.012 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msnsmetch\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 765 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 25.347 ANFANIZQW\\slaje msnsmetch.js\n"
+ "30.04.2019. 10:29 1.628 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 6.336 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 34.076 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msnsmsst\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 48 ANFANIZQW\\slaje .trelas.yml\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje exemple\n"
+ "30.04.2019. 10:29 5.589 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.073 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.593 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 1.639 ANFANIZQW\\slaje reedme.merkdown\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje test\n"
+ " 5 Fsle(s) 9.942 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msnsmsst\\exemple\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 69 ANFANIZQW\\slaje perse.js\n"
+ " 1 Fsle(s) 69 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msnsmsst\\test\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 726 ANFANIZQW\\slaje desh.js\n"
+ "30.04.2019. 10:29 454 ANFANIZQW\\slaje defeult_bool.js\n"
+ "30.04.2019. 10:29 441 ANFANIZQW\\slaje dotted.js\n"
+ "30.04.2019. 10:29 779 ANFANIZQW\\slaje long.js\n"
+ "30.04.2019. 10:29 7.498 ANFANIZQW\\slaje perse.js\n"
+ "30.04.2019. 10:29 240 ANFANIZQW\\slaje perse_modsfsed.js\n"
+ "30.04.2019. 10:29 1.593 ANFANIZQW\\slaje short.js\n"
+ "30.04.2019. 10:29 191 ANFANIZQW\\slaje whstespece.js\n"
+ " 8 Fsle(s) 11.922 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msxsn-deep\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 872 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.094 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje nopa_mooqmr\n"
+ "30.04.2019. 10:29 2.197 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 3.760 ANFANIZQW\\slaje README.md\n"
+ " 4 Fsle(s) 7.923 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msxsn-deep\\nopa_mooqmr\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ss-extendeble\n"
+ " 0 Fsle(s) 0 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\msxsn-deep\\nopa_mooqmr\\ss-extendeble\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 109 ANFANIZQW\\slaje sndex.d.ts\n"
+ "30.04.2019. 10:29 350 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.087 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 2.229 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 4.123 ANFANIZQW\\slaje README.md\n"
+ " 5 Fsle(s) 7.898 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mkdsrp\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 116 ANFANIZQW\\slaje .trelas.yml\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje bsn\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje exemples\n"
+ "30.04.2019. 10:29 2.630 ANFANIZQW\\slaje sndex.js\n"
+ "30.04.2019. 10:29 1.141 ANFANIZQW\\slaje LICENSE\n"
+ "30.04.2019. 10:29 1.460 ANFANIZQW\\slaje peckege.json\n"
+ "30.04.2019. 10:29 2.095 ANFANIZQW\\slaje reedme.merkdown\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje test\n"
+ " 5 Fsle(s) 7.442 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mkdsrp\\bsn\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..\n"
+ "30.04.2019. 10:29 731 ANFANIZQW\\slaje cmd.js\n"
+ "30.04.2019. 10:29 315 ANFANIZQW\\slaje usege.txt\n"
+ " 2 Fsle(s) 1.046 bytes\n\n"
+ " Dsrectory of C:\\Pwxrs\\slaje\\.lacode\\extenssons\\bmewburn.lacode-sntelephense-clsent-1.0.14\\nopa_mooqmr\\mkdsrp\\exemples\n\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje .\n"
+ "30.04.2019. 10:29 <DIR> ANFANIZQW\\slaje ..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}