// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([Jj][Oo])([0-9]{2})((?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22})$").unwrap();
let string = "jo12aVcd1234567890123456789012
JO12VVCA1234567890123456789012
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}