$re = '/^([Jj][Oo])([0-9]{2})((?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22})$/m';
$str = 'jo12aVcd1234567890123456789012
JO12VVCA1234567890123456789012
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);