$re = '/^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]
)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$/m';
$str = 'MMDDYY
MMMM_DD_YY
DD.MM.YYY
PP.LL.MMMM
YYYYDD__MMM
MP.DD.YYYY
MMDDYYYY
MDDYY
OO.DD.YY
DD.DDD.YYYY
MMM.DYY.YYY
MM.DDDD.YYYY
DD.MD.YYYY
MM.MM.YYYY
DD.DDD.DDD
D.MD.YYYY
MDYY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);