import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\\/_]\n"
+ ")([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$";
final String string = "MMDDYY\n"
+ "MMMM_DD_YY\n"
+ "DD.MM.YYY\n"
+ "PP.LL.MMMM\n"
+ "YYYYDD__MMM\n"
+ "MP.DD.YYYY\n"
+ "MMDDYYYY\n"
+ "MDDYY\n"
+ "OO.DD.YY\n"
+ "DD.DDD.YYYY\n"
+ "MMM.DYY.YYY\n"
+ "MM.DDDD.YYYY\n"
+ "DD.MD.YYYY\n\n"
+ "MM.MM.YYYY\n"
+ "DD.DDD.DDD\n"
+ "D.MD.YYYY\n"
+ "MDYY";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}