re = /^[!$#@%a-zA-Z0-9]*(?=[!$#@%]*)(?=[A-Z]*)(?=[0-9]*)(?=[a-z]*)$/
str = '1K!dfa'
# Print the match result
str.match(re) do |match|
puts match.to_s
end