using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[!$#@%a-zA-Z0-9]*(?=[!$#@%]*)(?=[A-Z]*)(?=[0-9]*)(?=[a-z]*)$";
string input = @"1K!dfa";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}