import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Timestamp>\\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s+\\d+\\s+\\d+:\\d+:\\d+)\\b\\s+(?P<FW_ip_addr>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?P<Event_id>%\\w+-\\d+-\\d+):\\s+(?P<Event_message>\\d+ in use, \\d+ most used)";
final String string = "Jul 25 23:57:12 210.56.128.109 %PIX-6-302010: 851 in use, 7079 most used";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}