package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\s+\d+\s+\d+:\d+:\d+)\b\s+(?P<FW_ip_addr>\d+\.\d+\.\d+\.\d+)\s+(?P<Event_id>%\w+-\d+-\d+):\s+(?P<Event_message>\d+ in use, \d+ most used)`)
var str = `Jul 25 23:57:12 210.56.128.109 %PIX-6-302010: 851 in use, 7079 most used`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}