re = /(?ms)\b\w*\b(?=\-\>.*)/
str = 'This is [INFO] 29 Jun- 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence SYSLOG- dds
This is my [second] sentence.(?<=\\[).*?(?=\\].*)
(?ms)(?<=\\s)\\w*(?=\\-\\>.*)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end