using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)\b\w*\b(?=\-\>.*)";
string input = @"This is [INFO] 29 Jun- 2018 06:06:49,620 SYSLOG->|datetime:20180629060649618+0000|
my first sentence SYSLOG- dds
This is my [second] sentence.(?<=\[).*?(?=\].*)
(?ms)(?<=\s)\w*(?=\-\>.*)";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}