import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\\"en\\\": {0,1}(\\\".+), {0,1}\\\"\\w\\w\\\": {0,1}(\\\".+\\\")\\},{0,1}";
final String string = "{\"en\": \"Male\", \"es\": \"Macho\"},\n"
+ "{\"en\": \"Female\", \"es\": \"Hembra\"},\n"
+ "{\"en\":\"Population\",\"es\":\"Población\"},\n"
+ "{\"en\": \"% of total population\", \"es\": \"% de la población total\"},\n"
+ "{\"en\": \"All cancers\", \"es\": \"Todos los cánceres\"},\n"
+ "{\"en\": \"All cancers but C44\", \"es\": \"Todos los cánceres pero C44\"},\n"
+ "{\"en\": \"Number of cases\", \"es\": \"Numero de casos\"},\n"
+ "{\"en\": \"Age Group\", \"es\": \"Grupo de edad\"},\n"
+ "{\"en\": \"Year\", \"es\": \"Año\"},\n"
+ "{\"en\": \"years\", \"es\": \"años\"},\n"
+ "{\"en\": \"years old\", \"es\": \"años\"},\n"
+ "{\"en\": \"Age-standardized incidence rate per\", \"es\": \"Tasa de incidencia estandarizada por edad por\"},\n"
+ "{\"en\": \"Cumulative incidence risk (percent)\", \"es\": \"Riesgo de incidencia acumulada (porcentaje)\"},\n"
+ "{\"en\": \"cancer sites\", \"es\": \"sitios de cáncer\"},\n"
+ "{\"en\": \"Time trend analysis need at least 2 years data\", \"es\": \"El análisis de tendencia temporal necesita al menos 2 años de datos\"},\n"
+ "{\"en\": \"Age at diagnosis\", \"es\": \"Edad al diagnóstico\"},\n"
+ "{\"en\": \"Estimated annual percentage change\", \"es\": \"Cambio porcentual anual estimado\"},\n"
+ "{\"en\": \"Regional registries\", \"es\": \"Registros regionales\"}";
final String subst = "\\1;\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}