using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\""en\"": {0,1}(\"".+), {0,1}\""\w\w\"": {0,1}(\"".+\"")},{0,1}";
string substitution = @"\1;\2";
string input = @"{""en"": ""Male"", ""es"": ""Macho""},
{""en"": ""Female"", ""es"": ""Hembra""},
{""en"":""Population"",""es"":""Población""},
{""en"": ""% of total population"", ""es"": ""% de la población total""},
{""en"": ""All cancers"", ""es"": ""Todos los cánceres""},
{""en"": ""All cancers but C44"", ""es"": ""Todos los cánceres pero C44""},
{""en"": ""Number of cases"", ""es"": ""Numero de casos""},
{""en"": ""Age Group"", ""es"": ""Grupo de edad""},
{""en"": ""Year"", ""es"": ""Año""},
{""en"": ""years"", ""es"": ""años""},
{""en"": ""years old"", ""es"": ""años""},
{""en"": ""Age-standardized incidence rate per"", ""es"": ""Tasa de incidencia estandarizada por edad por""},
{""en"": ""Cumulative incidence risk (percent)"", ""es"": ""Riesgo de incidencia acumulada (porcentaje)""},
{""en"": ""cancer sites"", ""es"": ""sitios de cáncer""},
{""en"": ""Time trend analysis need at least 2 years data"", ""es"": ""El análisis de tendencia temporal necesita al menos 2 años de datos""},
{""en"": ""Age at diagnosis"", ""es"": ""Edad al diagnóstico""},
{""en"": ""Estimated annual percentage change"", ""es"": ""Cambio porcentual anual estimado""},
{""en"": ""Regional registries"", ""es"": ""Registros regionales""}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}