$re = '/((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))/';
$str = '12
1
1234
00121300';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);