package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))`)
var str = `12
1
1234
00121300`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}