import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:(?:[1-9]?\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.?\\b){4}(?!\\S)";
final String string = "Validating IP V 4\n\n"
+ "1.1.1.1\n"
+ "2.2.2.2\n"
+ "3.3.3.3\n"
+ "4.4.4.4\n"
+ "5.5.5.5\n"
+ "6.6.6.6\n"
+ "7.7.7.7\n"
+ "8.8.8.8\n"
+ "9.9.9.9\n"
+ "10.10.10.10\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
+ "A single character of: a, b or c\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}