re = /^[=-]?[0-9]+(\.[0-9]*)?$/m
str = '1231231231231231231
asdjasdjasd123
12123123.12312
1982737.122
-123.123
-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end