package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[=-]?[0-9]+(\.[0-9]*)?$`)
var str = `1231231231231231231
asdjasdjasd123
12123123.12312
1982737.122
-123.123
-22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}