import Foundation
let pattern = #"\<\!--[\s\r\n-]*[\w\r\n-\W]*?[\s\r\n-]*--\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
t('bbbb',a,b,c)
t("aaaa")
t("aaaa')
t('aaaa') t('xxxx') // rrrr
t('bbbb',a,1)
// t('bbbb',{x:1,y:"(,)",z:[]},1)
t('中\n国')
//t(" fdgdfgfd df dfgdfgdf")
<!-- dfdfdf -->
<!---sdsdsd --->
<!--a-->
<!-- 中文 -->
<!--
ewewewe
//-->
<!--
ewewewe
//-->
<!--
function displayMsg()
{
alert("Hello World!")
}
//-->
fdff
/*
fdfdfdfsddssddsdsddsdsdsds
sdsdsd
dsdfsdfsd
fsdfsdfsdfsdf
*/
/******dsdsdsdds*/
/*dsdsdsdds*/
/*********/
ddd //dddd/*sdds*/
//This is a comment 1
let a= 1
// This is a comment 2
// This is a comment 3
function test(){
... //This is a comment 3
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)