const regex = /\<\!--[\s\r\n-]*[\w\r\n-\W]*?[\s\r\n-]*--\>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<\\!--[\\s\\r\\n-]*[\\w\\r\\n-\\W]*?[\\s\\r\\n-]*--\\>', 'gm')
const str = `t('bbbb',a,b,c)
t("aaaa")
t("aaaa')
t('aaaa') t('xxxx') // rrrr
t('bbbb',a,1)
// t('bbbb',{x:1,y:"(,)",z:[]},1)
t('中\\n国')
//t(" fdgdfgfd df dfgdfgdf")
<!-- dfdfdf -->
<!---sdsdsd --->
<!--a-->
<!-- 中文 -->
<!--
ewewewe
//-->
<!--
ewewewe
//-->
<!--
function displayMsg()
{
alert("Hello World!")
}
//-->
fdff
/*
fdfdfdfsddssddsdsddsdsdsds
sdsdsd
dsdfsdfsd
fsdfsdfsdfsdf
*/
/******dsdsdsdds*/
/*dsdsdsdds*/
/*********/
ddd //dddd/*sdds*/
//This is a comment 1
let a= 1
// This is a comment 2
// This is a comment 3
function test(){
... //This is a comment 3
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}