$re = '@(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass="(?:[^"]*\s)?c01[\s"])(?:(?!<p[\s>]).)*?\K\.(?=.*?</p>)@m';
$str = '<p class="c01 c02">lorem ipsum. dolor sit. amet sed.</p>
<p class="c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>';
$subst = "$0 #";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;