using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass=""(?:[^""]*\s)?c01[\s""])(?:(?!<p[\s>]).)*?\K\.(?=.*?</p>)";
string substitution = @"$0 #";
string input = @"<p class=""c01 c02"">lorem ipsum. dolor sit. amet sed.</p>
<p class=""c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class=""c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class=""c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}