const regex = /({})\1|[{]\s*?(\S*?|\S*?\(.*?\)|['][^']*?[']|["][^"]*?["]|["][^"]*?["]\.\(.*?\))(?:!(\S+?))?\s*?[}]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({})\\1|[{]\\s*?(\\S*?|\\S*?\\(.*?\\)|[\'][^\']*?[\']|["][^"]*?["]|["][^"]*?["]\\.\\(.*?\\))(?:!(\\S+?))?\\s*?[}]', 'g')
const str = `{0.concat("8a b c d e", 6)}
s df s sd{"one field name".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat("8a b c d e", 6)}
ascdac{ "one fieldname".toFixed(7 , 8) }
ascdac{ "onefi eldname" }
{onefieldname.toFixed(7 , 8)}
dfgsdg { "onefieldname".toFixed(7 , 8)}
{onefieldname: "toFixed(7 , 8)"}
{"onefieldname": "toFixed(7 , 8)"}
{ "onefiel dname" : "toFixed(7 , 8)"}
{ "onefiel dname": 8}
{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8)} }
{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8) }}
{ "onefiel dname" : {onefieldname.toFixed(7 , 8)} }
{ "onefiel dname" : { onefieldname.toFixed(7 , 8)} }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}