import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\})\\1|[\\{]\\s*?(\\S*?|\\S*?\\(.*?\\)|['][^']*?[']|[\"][^\"]*?[\"]|[\"][^\"]*?[\"]\\.\\(.*?\\))(?:!(\\S+?))?\\s*?[\\}]";
final String string = "{0.concat(\"8a b c d e\", 6)}\n"
+ "s df s sd{\"one field name\".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat(\"8a b c d e\", 6)} \n\n"
+ "ascdac{ \"one fieldname\".toFixed(7 , 8) }\n"
+ "ascdac{ \"onefi eldname\" }\n"
+ "{onefieldname.toFixed(7 , 8)}\n"
+ "dfgsdg { \"onefieldname\".toFixed(7 , 8)}\n"
+ "{onefieldname: \"toFixed(7 , 8)\"}\n"
+ "{\"onefieldname\": \"toFixed(7 , 8)\"}\n"
+ "{ \"onefiel dname\" : \"toFixed(7 , 8)\"}\n"
+ "{ \"onefiel dname\": 8}\n\n"
+ "{ \"onefiel dname\" : {\"onefi eldname\".toFixed(7 , 8)} }\n"
+ "{ \"onefiel dname\" : {\"onefi eldname\".toFixed(7 , 8) }}\n"
+ "{ \"onefiel dname\" : {onefieldname.toFixed(7 , 8)} }\n"
+ "{ \"onefiel dname\" : { onefieldname.toFixed(7 , 8)} }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}