// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^`~!@#$%^&*()_+={}\[\]|\\:;“’<,>.?๐฿]*$").unwrap();
let string = "asdad
sdf@323
asdasdadq@3333
[][]asd
dddddd[
127 elmer road ??<>()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}