re = /(\w+)(?!\()\W+/m
str = 'y ~ word1+word2 - 3word:word4 ** word5 + Function(word6)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end