$re = '/(\w+)(?!\()\W+/m';
$str = 'y ~ word1+word2 - 3word:word4 ** word5 + Function(word6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);