$re = '/([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$/m';
$str = 'pagamento fattura 003235 2071/2022
pagamento fattura 003235/cli 2071/2022
pagamento fattura 003235-cli 2071-2022
pagamento fattura 003235 2071-2022
pagamento fattura 003235 cli 2071 2022
pagamento fattura 003235 2071 2022
pagamento fattura 003235 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);