const regex = /([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{2,6})[\\s\\D]*([0-9]{1,6})[\\s\\D]*((20){0,1}([0-9]{2}))$', 'gm')
const str = `pagamento fattura 003235 2071/2022
pagamento fattura 003235/cli 2071/2022
pagamento fattura 003235-cli 2071-2022
pagamento fattura 003235 2071-2022
pagamento fattura 003235 cli 2071 2022
pagamento fattura 003235 2071 2022
pagamento fattura 003235 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/2022
pagamento fattura cliente 003235 nr. 2071 del 20/12/22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}