# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Entry>((?!<\/Entry>).)*<\/Entry>"
test_str = ("<Entry>\n"
" <Type>Unknown</Type>\n"
" <DateTime>11/28/2017 11:19:49.652</DateTime>\n"
" <Level>Exception</Level>\n"
" <Host>CNTX-PROD-WEB-A</Host>\n"
" <ThreadID>139</ThreadID>\n"
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>\n"
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>\n"
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>\n"
"</Entry>\n"
"<Entry>\n"
" <Type>Unknown</Type>\n"
" <DateTime>11/28/2017 11:19:49.652</DateTime>\n"
" <Level>Exception</Level>\n"
" <Host>CNTX-PROD-WEB-A</Host>\n"
" <ThreadID>139</ThreadID>\n"
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>\n"
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>\n"
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>\n"
"</Entry>\n"
"<Entry>\n"
" <Type>Unknown</Type>\n"
" <DateTime>11/28/2017 11:19:49.652</DateTime>\n"
" <Level>Exception</Level>\n"
" <Host>CNTX-PROD-WEB-A</Host>\n"
" <ThreadID>139</ThreadID>\n"
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>\n"
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>\n"
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>\n"
"</Entry>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.