#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<Entry>((?!<\/Entry>).)*<\/Entry>"
Local $sString = "<Entry>" & @CRLF & _
" <Type>Unknown</Type>" & @CRLF & _
" <DateTime>11/28/2017 11:19:49.652</DateTime>" & @CRLF & _
" <Level>Exception</Level>" & @CRLF & _
" <Host>CNTX-PROD-WEB-A</Host>" & @CRLF & _
" <ThreadID>139</ThreadID>" & @CRLF & _
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>" & @CRLF & _
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>" & @CRLF & _
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>" & @CRLF & _
"</Entry>" & @CRLF & _
"<Entry>" & @CRLF & _
" <Type>Unknown</Type>" & @CRLF & _
" <DateTime>11/28/2017 11:19:49.652</DateTime>" & @CRLF & _
" <Level>Exception</Level>" & @CRLF & _
" <Host>CNTX-PROD-WEB-A</Host>" & @CRLF & _
" <ThreadID>139</ThreadID>" & @CRLF & _
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>" & @CRLF & _
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>" & @CRLF & _
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>" & @CRLF & _
"</Entry>" & @CRLF & _
"<Entry>" & @CRLF & _
" <Type>Unknown</Type>" & @CRLF & _
" <DateTime>11/28/2017 11:19:49.652</DateTime>" & @CRLF & _
" <Level>Exception</Level>" & @CRLF & _
" <Host>CNTX-PROD-WEB-A</Host>" & @CRLF & _
" <ThreadID>139</ThreadID>" & @CRLF & _
" <Request.URL>https://bonnier.magazine-services.net:44314/CS/Account.aspx?accountid=3622083</Request.URL>" & @CRLF & _
" <Comment>Subscript =3420512 - Has an invalid state. The publication is ceased, but the subscription is not canceled.</Comment>" & @CRLF & _
" <ExceptionMessage>Issue with subscription: 3420512</ExceptionMessage>" & @CRLF & _
"</Entry>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")