using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"line-height: (.*)em;";
string input = @"line-height: 1.5em;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}