import Foundation
let pattern = #"([\[|(].+?[\]|)])(:\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
India , officially the Republic of India (Hindi: Bharat
Ga ? arajya), is a country in South Asia. It is the seventh-largest country by area, the second-most populous country, and the most populous democracy in the world. Bounded by the Indian Ocean on the south, the Arabian Sea on the south
asdlfasjdflksd [2]
slkdjwed[3223][123][jhhjkzu7]
some references have a page number: [678]:7898[rtzu]
(lis jkjkh j k lis jkjkh j k ? ten ? ten)hjjh jgj jh g[456]h (jjhhzjhkjjk)
[g][45]:789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)