import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\[|(].+?[\\]|)])(:\\d+)?";
final String string = "India , officially the Republic of India (Hindi: Bharat \n"
+ "Ga ? arajya), is a country in South Asia. It is the seventh-largest country by area, the second-most populous country, and the most populous democracy in the world. Bounded by the Indian Ocean on the south, the Arabian Sea on the south\n\n"
+ "asdlfasjdflksd [2]\n"
+ "slkdjwed[3223][123][jhhjkzu7]\n"
+ "some references have a page number: [678]:7898[rtzu]\n"
+ "(lis jkjkh j k lis jkjkh j k ? ten ? ten)hjjh jgj jh g[456]h (jjhhzjhkjjk)\n\n"
+ "[g][45]:789";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}