import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+.ACT\\w+),?.*";
final String string = "FormAttachments.ACT_RequiredImages_Load\n\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus\n"
+ "FormAttachments.ACT_RequiredImages_Load,FormAttachments.SUB_UpdateTireReplacementRequirements_NoAttachments,FormAttachments.SUB_UpdateTireReplacementRequirements,WorkOrder.SUB_CheckAttachmentsRequirements,WorkOrder.SUB_GetWorkOrderSUBMenuStatus,WorkOrder.SUB_CheckWorkOrderStatus,WorkOrder.ACT_ShowMaintHome_FromLoading\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}