import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Content\\/([A-Z][a-zA-z0-9\\_]*\\/)*(BP|T|M|MI)\\_[A-Z].[a-zA-Z]+\\.(uasset|umap)";
final String string = "Content/Ass/Ass/Bdd_01/BP_Asset.uasset";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}