#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Content\/([A-Z][a-zA-z0-9\_]*\/)*(BP|T|M|MI)\_[A-Z].[a-zA-Z]+\.(uasset|umap)"
Local $sString = "Content/Ass/Ass/Bdd_01/BP_Asset.uasset"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")