using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<ssn>(?<!\d{1})\d{3}[\s-]+\d{2}[\s-]+\d{4}(?!\d{1})|(?<!\d{1})\d{9}(?!\d{1}))|(?<creditCard>(?<![0-9]{1})(?:4[0-9]{12}(?:[0-9]{3})?|\d{4}[\s-]+\d{4}[\s-]+\d{4}[\s-]+\d{4}|\d{4}\d{4}\d{4}\d{4}|(?:5[1-5][0-9]{2}|222[1-9]|22[3-9][0-9]|2[3-6][0-9]{2}|27[01][0-9]|2720)[0-9]{12}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})(?![0-9]{1}))";
string input = @"113-01-1111
213 81 1111
1553 01 1111
153 01 1111
153 01 11113
153-01-1111
153-01-1111
1313 01 11511
153-01-1111
153-01-1111
\n113-01-1111
\t113-01-11114
\t113-01-1111\t
\t 113-01-1111\t
\t113-01-1111 4
\t113-01-11114
\t113-01-1111
Robert Aragon 489‑36‑8350 4929‑3813‑3266‑4295
Ashley Borden 514‑14‑8905 5370‑4638‑8881‑3020
Thomas Conley 690‑05‑5315 4916‑4811‑5814‑8111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}