#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<ssn>(?<!\d{1})\d{3}[\s-]+\d{2}[\s-]+\d{4}(?!\d{1})|(?<!\d{1})\d{9}(?!\d{1}))|(?<creditCard>(?<![0-9]{1})(?:4[0-9]{12}(?:[0-9]{3})?|\d{4}[\s-]+\d{4}[\s-]+\d{4}[\s-]+\d{4}|\d{4}\d{4}\d{4}\d{4}|(?:5[1-5][0-9]{2}|222[1-9]|22[3-9][0-9]|2[3-6][0-9]{2}|27[01][0-9]|2720)[0-9]{12}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})(?![0-9]{1}))"
Local $sString = "113-01-1111" & @CRLF & _
"213 81 1111" & @CRLF & _
"1553 01 1111" & @CRLF & _
"153 01 1111" & @CRLF & _
"153 01 11113" & @CRLF & _
"153-01-1111" & @CRLF & _
" 153-01-1111 " & @CRLF & _
"1313 01 11511" & @CRLF & _
"" & @CRLF & _
"153-01-1111" & @CRLF & _
" 153-01-1111 " & @CRLF & _
"\n113-01-1111 " & @CRLF & _
"\t113-01-11114" & @CRLF & _
"\t113-01-1111\t" & @CRLF & _
"\t 113-01-1111\t" & @CRLF & _
"\t113-01-1111 4" & @CRLF & _
"\t113-01-11114" & @CRLF & _
"\t113-01-1111" & @CRLF & _
"" & @CRLF & _
"Robert Aragon 489‑36‑8350 4929‑3813‑3266‑4295" & @CRLF & _
"Ashley Borden 514‑14‑8905 5370‑4638‑8881‑3020" & @CRLF & _
"Thomas Conley 690‑05‑5315 4916‑4811‑5814‑8111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")